Server Buddies
Server Buddies Server Management LiveZilla Live Help
Server Management Spanish
Providing Dedicated Server Solutions Just a Click AWAY
Contact Us
About Us
server management Server Tweaking Server Monitoring HelpDesk Support Security Audit
Cpanel Support
Plesk Support
Ensim Support
Webmin Support
Directadmin Support
We Accept
We accept Visa, Mastercard, Discover and American Express credit cards.
Paypal is also accepted. The email address to use to make PayPal payment to us is:
Paypal Accepted Paypal Accepted
2Checkout Accepted
30-Day MoneyBack Guarantee!

A week ago I hired to install for me the required and very specific video and audio codecs needed for my website to run properly. They did not only install the required codecs, but they found that I need more requirements installed. After my confirmation, they installed the additional requirements for free. They always give me a nice and professional answer to my emails and they did the job very fast, very accurate and very professional. They provide all the information on where/how to find all the stuff I needed. Thank you ServerBuddies for the GREAT and professional service , I'm very amazed how fast and professional was everything done !
See more reviews

Exim Remote Code Execution Vulnerability Notification CVE-2012-5671

Exim Remote Code Execution Vulnerability Notification CVE-2012-5671


A remote code execution vulnerability exists in Exim versions between 4.70 and 4.80, inclusive. Exim is the mail transfer agent used by cPanel & WHM.

Security Rating

This vulnerability has been rated as Critical[1] by the cPanel Security team.


A remote code execution flaw in Exim has been discovered by an internal audit performed by the Exim developers[2]. This vulnerability may lead to arbitrary code execution with the privileges of the user executing the Exim daemon. In some circumstances this may lead to privilege escalation.

The vulnerability is tied to the DKIM support introduced in Exim 4.70. It has been assigned CVE-2012-5671[3].

The following Exim RPMs, as distributed by cPanel, Inc. are known to be vulnerable:


These RPMs were shipped as part of cPanel & WHM versions 11.32 and 11.34.


Servers that are using the default DKIM verification settings provided with cPanel & WHM 11.32 and newer are not vulnerable. The default settings disable DKIM key verification by adding the following to /etc/exim.conf

   warn control = dkim_disable_verify

This prevents the exploitable code from being available during exim execution.

To fully resolve the issue cPanel has produced new Exim RPMs for cPanel & WHM version 11.32 and 11.34. Server Owners are strongly urged to update their cPanel & WHM installations to the following versions:

    cPanel & WHM
    cPanel & WHM

Exim RPMs are distributed through cPanel’s package management system. All cPanel & WHM servers receiving updates automatically will receive the updated Exim RPM during normal update and maintenance operations (upcp). Servers with automatic updates disabled will require action in order to receive the update. We recommend all customers to update to the latest releases of 11.32 and 11.34 as soon as possible.

Servers who have disabled Exim updates, via the Update Preferences interface in WHM, are strongly urged to re-enable updates.

To perform a manual update of cPanel & WHM, perform the following:

    Login to your server as root using SSH
    Execute the following command on the command line:


Updated cPanel & WHM 11.32, and 11.34, servers will have the following Exim RPM:    exim-4.80-3

Remember, we listen to you! Any comments/suggestions should be sent to

RedHat Support Debian Support Gentoo Linux Support FreeBSD Support Fedora Support Ubuntu Support CentOS Support SuSe Support
Home | Services | Order | Support | News | About Us | Contact | Site Map | Refund & Privacy Policy | Blog